Actually, all Linuxes are alike. Almost. In the end, you run into problems because one system is by default installed with some library that another does not use. Since these libraries are installed only once, the challenge is to find out which libraries need to be installed and which are already there, and this is again different from system to system.

Thus, not the Linuxes are different, but their installation evolves over time. I will give some hints for installing MAME on different systems on this page.

Running MAME

MAME is dynamically linked against some libraries which may not be installed on your machine.

But fixing this is a simple job which you have to do only once. The following commands have been tested on a fresh installation. After installing, you should be able to run MAME. (Please report if you find a different situation.)

Unfortunately, different Linux flavors come with different package installers. And to make things worse, they use different package names for the same libraries.

openSUSE Tumbleweed

sudo zypper install libSDL2_ttf-2_0-0
sudo zypper install libQt5Widgets5

Ubuntu 19.10, Linux Mint 19.3

sudo apt install libsdl2-ttf-2.0-0
sudo apt install libqt5widgets5